Downloads: 6552

Reviews: 21


Login or Sign up to write a review

Reviews from the community

  • Simply wonderful! I had just to add a config file (.conf) inside /etc/telegraf/telegraf.d/ and change vcgencmd path from /opt/vc/bin to /usr/bin/ . Mind that I am using a rasberry pi4b, latest pi os. Added telegraf to video group (sudo usermod -G video telegraf), restart service and done! Thanks a lot!
    December 26th 2021, 5:06 pm
    by jean717p
    Revision: 1
  • I was having trouble with the GPU temp showing up. I went to my telegraf config and found the input that reports GPU temp. Turns out the path it had for vcgencmd was incorrect. Changing the path from ".../opt/vc/bin..." to ".../usr/bin..." and then restarting the process got it working.
    December 17th 2021, 9:20 pm
    by timpasquini
    Revision: 1
  • This is a great dashboard, but where can I ask questions with regards extracting data to the pages. Generally this was all executed and worked, apart from the issue I have with the version of telegraf needed. I installed the latest version which caused an issue where the telegraf service would not start. After rolloing back to version 1.18.2, everything worked without hassles. The only issue that I currently have is I have 6 RASPI delivering data to the database. All data is present apart from the gpu_temperature. This only shows for the first pi, all the other gpu_temperatures show as N/A. If I do the check locally on each pi, the details are present. So if anyone has some suggestion how to get this fixed would be great. Thanks Lawrence
    August 30th 2021, 12:08 pm
    by Lawrence Lamprecht
    Revision: 1
  • I have just installed this and I cannot get telegraf stated on my RASPI. All the research I have done points to installing a previous version of Telegraf. Only I cannot find an installation file for the RASPI. Any advice would be appreciated Thx
    August 24th 2021, 7:03 am
    by Lawrence Lamprecht
    Revision: 1
  • This is great. Worked from the first try. And so much good stats! Thank you. For neewbies: read the reviews if you have troubles with dependent software. Every answer is there
    January 16th 2021, 8:08 pm
    by sgerodes
    Revision: 1
  • Anyone have a guide how to set this up? Installed Grafana, Influxdb and Telegraf but get allot of fetching data errors. Hope someone can help. Thx
    December 30th 2020, 7:26 pm
    by andyvrd
    Revision: 1
  • Great work! But if you can migrate it to the Influxdb v2 (i mean FLUX) you will be my personal hero ;)
    November 21st 2020, 1:34 pm
    by mister easter
    Revision: 1
  • Excellent Dashboard for Raspberry Py
    October 11th 2020, 8:07 am
    by Facu de la Cruz
    Revision: 1
  • Great dashboard. Does what it is supposed to do, even as beginner I was able to install it.
    September 30th 2020, 1:25 pm
    by thomasc6
    Revision: 1
  • Thank you Jorge. Installed and working. Is there a way to follow a specific process?! That is, I have a PWS Weather Station running under WeeWX application. Is there a way to track this process through the RPi Monitoring? The following is an external step-by-step for those in need: Thanks, Xant
    May 17th 2020, 8:44 pm
    by zxant
    Revision: 1
  • Thank you Jorge, great dash and now monitoring my RPi. Is there a way to monitor a specific process?! That is, I have a PWS Weather Station, running through WeeWX app in my RPi4, and would like to keep posted in case of any. Thanks, Xant
    May 13th 2020, 4:07 am
    by zxant
    Revision: 1
  • cool thx
    April 17th 2020, 9:11 pm
    by firewall68
    Revision: 1
  • Thank you for this! For the newbies arriving here (like I did), please pay attention to the review by itemir from 2nd Feb 2020 as it expands on one of the dependencies. As well as Grafana, you'll also need to be running Telegraf and InfluxDB. It's likely you'll need to install these, if you haven't already. Grafana comes with an InfluxDB plugin built-in, but this doesn't mean you have an InfluxDB instance available to use. Telegraf is needed to collect data from your Pi, InfluxDB is needed to store the collected data and it's from here where Grafana can retrieve the stats. With regards to the GPU temperature showing N/A, I had to initially use a different approach to what's documented here before I managed to somehow get it working. Basically, the command /opt/vc/bin/vcgencmd measure_temp was continually throwing an error (I could see it spamming my system logs at /var/log/syslog). I worked around this with an approach based upon, but with the following modifications to the "old way": 1) Create an executable file, /usr/local/bin/, with the following: #!/bin/bash prefix="temp=" suffix="'C" gpu=$(/opt/vc/bin/vcgencmd measure_temp) gpu_temp=${gpu#$prefix} gpu_temp=${gpu_temp%$suffix} echo -e "{\"value\":$gpu_temp}" 2) Have this as the [[inputs.exec]] in /etc/telegraf/telegraf.conf: [[inputs.exec]] commands = ["/usr/local/bin/"] timeout = "5s" data_format = "json" name_override= "gpu_temperature" 3) Restart Telegraf with: sudo service telegraf restart If you have multiple Pis which you wish to monitor then you can just install Telegraf onto them and point them at your existing InfluxDB database. You can then choose the Pi to look at using the Server dropdown at the top of the dashboard.
    April 11th 2020, 9:42 pm
    by chillee
    Revision: 1
  • Cool dashboard. Thanks a lot for such a job. I want to add a hint for CPU frequency 1. Telegraf config [[inputs.exec]] commands = ["cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq"] name_override = "cpu_frequency" data_format = "value" data_type = "integer" 2. Query to get data in Mhz SELECT mean(value)/1000 as "cpu frequency" FROM "cpu_frequency" WHERE "host" =~ /$server$/ and $timeFilter GROUP BY time($interval), *
    February 5th 2020, 7:33 am
    by jokaorgua
    Revision: 1
  • This is cool plugin. Thank you Jorge for developing it. A couple of pointers for those who are running into problems. First of all, you need to have telegraf running ( and have the following additional configuration in /etc/telegraf/telegraf.conf file: # For Raspberry Pi plugin ( [[]] [[inputs.netstat]] [[inputs.file]] files = ["/sys/class/thermal/thermal_zone0/temp"] name_override = "cpu_temperature" data_format = "value" data_type = "integer" [[inputs.exec]] commands = ["/opt/vc/bin/vcgencmd measure_temp"] name_override = "gpu_temperature" data_format = "grok" grok_patterns = ["%{NUMBER:value:float}"] After doing this, you may need to restart telegraf, by doing "sudo service telegraf restart". Even after that, you may see a problem in the disk stats. In my case it was empty. After some digging, I found something what appears to be a bug. Go to "Disk Usage for XXX" dashboard and edit it, you will see a query, change it to the following (there is a tiny difference in the path section). SELECT mean(total) AS "total", mean(used) as "used" FROM "disk" WHERE "host" =~ /$server$/ AND "path" =~ /$mountpoint$/ AND $timeFilter GROUP BY time($interval), "host", "path" Do the same for "Disk Inodes for XXX", by copy pasting the following query: SELECT mean(inodes_used) as "used" FROM "disk" WHERE "host" =~ /$server$/ AND "path" =~ /$mountpoint$/ AND $timeFilter GROUP BY time($interval), "host", "path" These changes fixed it for me.
    February 2nd 2020, 3:24 am
    by itemir
    Revision: 1
  • Absolutely awesome. However, on some graphs (network usage, disk I/O & swap I/O) values for “in” are positive and “out” are negative. Not sure if that’s how it’s suppose to be but it looks strange. Also, no matter what I do I can’t get GPU temp for my RPi 4 with 4GB. I added the video group to the user and all entries for inputs.file and inputs.exec. Still shows N/A
    November 14th 2019, 5:30 pm
    by ginterpi
    Revision: 1
  • Looks good and al works apart from the network monitor. am I missing an input?
    October 19th 2019, 5:54 am
    by ssmale
    Revision: 1
  • Good stuff and a great dashboard! To note the configuration details at the bottom of the post need to be placed in the telegraf configuration file. Not sure why the network details are not populating but Ill try to tinker with it.
    October 17th 2019, 11:24 am
    by Blue Devil
    Revision: 1
  • Hello, can you please review that you have the next on your config? # Read metrics about disk usage by mount point [[inputs.disk]] ## By default stats will be gathered for all mount points. ## Set mount_points will restrict the stats to only the specified mount points. # mount_points = ["/"] ## Ignore mount points by filesystem type. ignore_fs = ["tmpfs", "devtmpfs", "devfs", "iso9660", "overlay", "aufs", "squashfs"] Maybe you have ignored something there? I can see my boot and my / partitions without any problem. The Networking part has been added into the telegraf config, take a look, I can see it working on my RasPi with wlan0, no problem at all.
    October 14th 2019, 12:16 am
    by Jorge de la Cruz
    Revision: 1
  • shows negative values in disk monitoring. broken network monitoring. my device Raspi4, Grafana v6.3.5 (commit: 67bad72), sd card + external USB3 HDD.
    September 21st 2019, 2:43 pm
    by Josef Dvořáček
    Revision: 1
Page of 2
Get this dashboard: